Kochen in langsam

../../../_images/P6217990_mini.jpg

Fast schon ein Klassiker aus dem Blog Anonyme Köche: Die Pappardelle al Ragù di Manzo. Ich habe das ganze um 11 Uhr angesetzt und gegen halb 9 war es dann fertig. Dazu selbstgemachte Nudeln.

Read more...

Vergrößern eines zpools auf FreeBSD 9.1

Schon länger betreibe ich einen Fileserver zuhause für alles was Platz braucht: Musik, Photos und Videos. Gestartet habe ich mit vier 1,5TB Festplatten als raidz1 unter FreeBSD. Hierbei dient einer der Platten als Redundanz und der pool bleibt vollständig falls eine Platte ausfällt. Als Nachteil bleiben von theoretisch 6TB nur knapp 4TB übrig. Mit der Zeit wachsen die Anforderungen und irgendwann waren auch diese 4TB zu wenig.

homeserver# zfs list
NAME               USED  AVAIL  REFER  MOUNTPOINT
tank              3.87T   134G  43.4K  /mnt/tank
tank/daten        3.87T   134G  3.87T  /mnt/tank/daten

Was also tun? Ein zpool mit raidz1 hat die Eigenschaft immer die Größe der kleinsten Festplatte als Grundlage zu nehmen (logisch, oder?). Also müssen alle 4 Platten ersetzt werden, da in meinem Fileserver nicht die Möglichkeit besteht weitere Festplatten hinzuzufügen. Da ich allerdings kein zweites Gerät parat habe, konnten nicht alle Daten einfach umkopiert werden.

Die Lösung ist etwas langwierig, aber einfach:

Read more...

FreeBSD 9 und ipv6 Gateway Probleme

Bereits vor Weihnachten habe ich mir von meinem Hoster ein ipv6-Subnetz für meinen vServer zuteilen lassen. Auf diesem läuft momentan FreeBSD 9.1. Im Normalfall ist die Zuweisung einer statischen ipv6-Adresse trivial, zwei Zeilen in der /etc/rc.conf reichen bereits aus:

ipv6_defaultrouter="xxxx:xxxx:xxxx:xxxx::1"
ifconfig_re0_ipv6="xxxx:xxxx:xxxx:xxxx:x::1/64"

Achtung: re0 ist die Bezeichnung meines Interfaces, diese kann variieren. Damit dies funktioniert, muss sich der Gateway im eigenen Subnetz befinden. Aus Verwaltungsgründen ist dies bei meinem Hoster nicht der Fall. Also muss eine statische Route her. Leider akzeptiert das Betriebssystem die Angabe des Routers so nicht. Die Lösung des Problems ist die Verwendung der link-local Adresse des Gateways. Korrekt konfigurierte Router antworten auf den Befehl:

ping6 ff02::2%re0

mit der Ausgabe:

PING6(56=40+8+8 bytes) fe80::XXXX:XXXX:XXXX:XXXX%re0 --> ff02::2%re0
16 bytes from fe80::YYYY:YYYY:YYYY:YYYY%re0, icmp_seq=0 hlim=64 time=1.511 ms

Hierbei ist fe80::YYYY:YYYY:YYYY:YYYY%re0 die link-local Adresse des Gateways. Hiermit ist dann die Konfiguration einfach:

route add -inet6 default fe80::YYYY:YYYY:YYYY:YYYY%re0

Und schon funktioniert alles.

Umzug

Nach einer langen Blog-Pause melde ich mich hier zurück. Neues Jahr, neuer Blog. Ich habe so gut es ging die Einträge des alten Blogs importiert. Er wird als Archiv aber weiter bestehen.